Degraded financial information

Incident Report for DNS Belgium

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 07:41 UTC

Identified

We are currently experiencing a temporary delay in response times from our accounting system. Our technical team is actively working to resolve the issue and restore normal service as quickly as possible.
During this time, financial data may be temporarily unavailable, and you may experience minor glitches.

We apologize for any inconvenience this may cause and appreciate your patience. We will keep you updated on the progress and notify you once the issue is resolved.

The delegation of domain names, EPP, MyRegistrations, DAS and WHOIS will not be affected.
Posted Apr 17, 2025 - 13:20 UTC
This incident affected: .be (EPP, My registrations).